Dock application experiencing issues

Incident Report for Dock

Resolved

The incident has been resolved
Posted Feb 24, 2026 - 16:15 UTC

Identified

The issue has been identified and the engineering team is working to fix. Customers should start to see improved performance.
Posted Feb 24, 2026 - 16:03 UTC

Investigating

Dock's engineering team is currently investigating the issue
Posted Feb 24, 2026 - 15:55 UTC
This incident affected: Web Application.